# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*added:[\s\S]*?(?=^[^+-])"
test_str = ("demo, demo-setga, Deployment (apps) has changed:\n"
"...\n"
"- image: \"imagedemo43\"\n"
"+ image: \"imagedemo44\"\n"
"...\n"
"demo, demo-app1, Deployment (apps) has been removed:\n"
"- # Source: /charts/app1/templates/deploy.yaml\n"
"- apiVersion: apps/v1\n"
"- imagePullSecrets:\n"
"- - name: demo-registry\n"
"+\n"
"demo, demo-app2, Deployment (apps) has changed:\n"
"...\n"
"- value: 4.2.0\n"
"+ value: 4.3.0\n"
"...\n"
"demo, demo-app4, Deployment (apps) has been added:\n"
"-\n"
"+ apiVersion: apps/v1\n"
"+ kind: Deployment\n"
"+ metadata:\n"
"+ heritage: Helm\n"
"+ imagePullSecrets:\n"
"+ - name: demo-registry\n"
"demo, demo-app9, Deployment (apps) has changed:\n"
"...\n"
"- value: 2.2.0\n"
"+ value: 4.3.0\n"
"...\n"
"demo, demo-app5, PodDisruptionBudget (policy) has been added:\n"
"-\n"
"+ apiVersion: policy/v1beta1\n"
"+ kind: PodDisruptionBudget\n"
"+ metadata:\n"
"+ app: app5\n"
"+ release: demo\n"
"../helm_var/test/dev/secrets.yaml.dec\n"
"demo, demo-app8, PodDisruptionBudget (policy) has been added:\n"
"-\n"
"+ # Source: test/charts/app5/templates/pdb.yaml\n"
"+ apiVersion: policy/v1beta1\n"
"+ matchLabels:\n"
"+ app: app5\n"
"+ release: demo\n"
"demo, demo-app9, Deployment (apps) has changed:\n"
"...\n"
"- value: 4.1.0\n"
"+ value: 9.3.0\n"
"...")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.