$re = '/(([(][\d]{2}[)])([\s])([\d]{4})([-])([\d]{4}))/m';
$str = '(12) 1234-1234
(71) 9200-12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);