re = /(([(][\d]{2}[)])([\s])([\d]{4})([-])([\d]{4}))/m
str = '(12) 1234-1234
(71) 9200-12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end