package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)BatchId\s*:\s*(?<batch>[^,]+),\s*RequestId\s*(?<RequestID>[^,]+),\s*Msg : Batch status to be update to (?<Status>[^,]+)`)
var str = `"message" : "BatchId : 7, RequestId : 100532188, Msg : Batch status to be update to SUCCESS",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}