$re = '/BatchId\s*:\s*(?<batch>[^,]+),\s*RequestId\s*(?<RequestID>[^,]+),\s*Msg : Batch status to be update to (?<Status>[^,]+)/m';
$str = '"message" : "BatchId : 7, RequestId : 100532188, Msg : Batch status to be update to SUCCESS",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);