import Foundation
let pattern = #"^(\d+,\s*'[^',]*).*(',[^,\n]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
119, 'Youth Campus,Janakpur', Janakpur
978, 'Yog Kumar Janta Campus, Balwa-3', Mahottari
806, 'Yerawati Aadarsha Multiple Campus, Lalmatiya Deukhuri, Dang', Dang
613, 'Yasok Campus, Yasok, Panchther', Panchthar
458, 'Yagyodaya Dudhnath Tharu Multiple Campus,Suddhodhan-3,Ramawapur', Rupandehi
1008, 'Yagnyabhumi Multiple Campus, Dharapani', Dhanusha
546, 'Xavier International College, Kamalpokhari,kath', Kathmandu
362, 'Xavier Academy Science College, Lazimpat, Kathmandu', Kathmandu
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)