const regex = /(?!^)[^@](?=.+@)(?!$)/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^)[^@](?=.+@)(?!$)', 'sg')
const str = `mhyunf@gmail.com`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);