import re
regex = re.compile(r"(?!^)[^@](?=.+@)(?!$)", flags=re.DOTALL)
test_str = "mhyunf@gmail.com"
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)