#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:[^\S\r\n]*)(=+)(?:[^\S\r\n]*)(.+?)(?:[^\S\r\n]*=+[^\S\r\n]*)?$"
Local $sString = "== Heading 1 ==" & @CRLF & _
"" & @CRLF & _
"lorem ipsum" & @CRLF & _
"" & @CRLF & _
"=== Sub-Heading 1 ===" & @CRLF & _
"" & @CRLF & _
"lorem ipsum" & @CRLF & _
"" & @CRLF & _
" ===Sub-Heading 2 with ugly formatting=== " & @CRLF & _
"" & @CRLF & _
"lorem ipsum" & @CRLF & _
"" & @CRLF & _
"=== Sub-Heading 3 without closing equal signs" & @CRLF & _
"" & @CRLF & _
"lorem ipsum" & @CRLF & _
"" & @CRLF & _
"== Heading 2 with ~= in the middle ==" & @CRLF & _
"" & @CRLF & _
"lorem ipsum"
Local $sSubst = "$1= $2 $1="
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)