package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^\S\r\n]*)(=+)(?:[^\S\r\n]*)(.+?)(?:[^\S\r\n]*=+[^\S\r\n]*)?$`)
var str = `== Heading 1 ==
lorem ipsum
=== Sub-Heading 1 ===
lorem ipsum
===Sub-Heading 2 with ugly formatting===
lorem ipsum
=== Sub-Heading 3 without closing equal signs
lorem ipsum
== Heading 2 with ~= in the middle ==
lorem ipsum`
var substitution = "$1= $2 $1="
fmt.Println(re.ReplaceAllString(str, substitution))
}