#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:No)*Yes){3}(?!.*Yes)"
Local $sString = "YesYesNoNoYes" & @CRLF & _
"YesNoNoYesNo" & @CRLF & _
"NoNoYesYesNo" & @CRLF & _
"YesYesYesNoNo" & @CRLF & _
"NoYesNoYesYes" & @CRLF & _
"NoNoYesNoYes" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")