$re = '/^(?:(?:No)*Yes){3}(?!.*Yes)/m';
$str = 'YesYesNoNoYes
YesNoNoYesNo
NoNoYesYesNo
YesYesYesNoNo
NoYesNoYesYes
NoNoYesNoYes
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);