package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(-?\d+)(?:\((\d+(?:\(\d+\))*)?\))?(?:\((\d+(?:\(\d+\))*)?\))?$`)
var str = `4
4(2(3))
4(2(3)(1))
4(2(3)(1))(6(5))
-4(2(3)(1))(6(5))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}