re = /^(-?\d+)(?:\((\d+(?:\(\d+\))*)?\))?(?:\((\d+(?:\(\d+\))*)?\))?$/m
str = '4
4(2(3))
4(2(3)(1))
4(2(3)(1))(6(5))
-4(2(3)(1))(6(5))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end