const regex = /(?<=[^\]])(\", ?\")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[^\\]])(\\", ?\\")', 'gm')
const str = `This is a [Gender: "male", "female"] tag
This is a [Normal tag] tag
[Fruits: "Banana", "Pineable", "Apple", "Dorian"]
They said "No, we don't", "We want more", etc.`;
const subst = `<$1/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);