re = /(?<=[^\]])(\", ?\")/m
str = 'This is a [Gender: "male", "female"] tag
This is a [Normal tag] tag
[Fruits: "Banana", "Pineable", "Apple", "Dorian"]
They said "No, we don\'t", "We want more", etc.'
subst = '<$1/>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result