// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)matei 200 inheritance").unwrap();
let string = "<?php
class Device {
protected $name;
protected $isOn = false;
function __construct($name = \"Unknown Device\") {
$this->name = $name;
}
function turnOn() {
$this->isOn = true;
echo \"{$this->name} is turned on.<br>\";
}
function turnOff() {
$this->isOn = false;
echo \"{$this->name} is turned off.<br>\";
}
function getStatus() {
$status = $this->isOn ? \"on\" : \"off\";
echo \"{$this->name} is currently {$status}.<br>\";
}
}
class Smartphone extends Device {
private $photos = 0;
function __construct($name = \"Smartphone\") {
parent::__construct($name);
}
function takePhoto() {
if ($this->isOn) {
$this->photos++;
echo \"Photo taken! (Total: {$this->photos} photos)<br>\";
} else {
echo \"Please turn on the {$this->name} first!<br>\";
}
}
function showPhotoCount() {
echo \"Number of photos: {$this->photos}<br>\";
}
}
echo \"<h3>Device Class:</h3>\";
$myDevice = new Device(\"Television\");
$myDevice->turnOn();
$myDevice->getStatus();
$myDevice->turnOff();
$myDevice->getStatus();
echo \"<br><h3>Smartphone Class:</h3>\";
$myPhone = new Smartphone(\"iPhone 15\");
$myPhone->getStatus();
$myPhone->takePhoto();
$myPhone->turnOn();
$myPhone->takePhoto();
$myPhone->takePhoto();
$myPhone->takePhoto();
$myPhone->showPhotoCount();
$myPhone->turnOff();
?>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}