re = /^(?:[0-9]{12}|[0-9]{10}[A-Z])$/m
str = '4024204455A
192345006900
4024204455A
192345006900
19234500690000000000
192345006900000A
This is a test 4024204455A this is a test
4024204455A this is a test
this is a test 4024204455A
This is a test4024204455A this is a test
4024204455Athis is a test
this is a test4024204455A
This is a test,4024204455A this is a test
:4024204455A: this is a test
this is a test##4024204455A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end