// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[0-9]{12}|[0-9]{10}[A-Z])$").unwrap();
let string = "4024204455A
192345006900
4024204455A
192345006900
19234500690000000000
192345006900000A
This is a test 4024204455A this is a test
4024204455A this is a test
this is a test 4024204455A
This is a test4024204455A this is a test
4024204455Athis is a test
this is a test4024204455A
This is a test,4024204455A this is a test
:4024204455A: this is a test
this is a test##4024204455A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}