#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)(?={{infobox).*?:(.*?)(?=\.\w+\|)\.(\w+)"
Local $sString = "{{Infobox xyz" & @CRLF & _
"|aaa= Xyz" & @CRLF & _
"|bbb= [[Xyz]]" & @CRLF & _
"|ccc=[[File:xyz.jpg|thumb|Xyz.]]" & @CRLF & _
"|ddd= {{lang|en|xyz}}" & @CRLF & _
"}}" & @CRLF & _
"" & @CRLF & _
"[[File:abc.jpg|thumb|Abc.]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")