re = /(?={{infobox).*?:(.*?)(?=\.\w+\|)\.(\w+)/mi
str = '{{Infobox xyz
|aaa= Xyz
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
}}
[[File:abc.jpg|thumb|Abc.]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end