const regex = /^(1[0-2]|0?[1-9]):([0-5][0-9])([AaPp][Mm])(?:\|(1[0-2]|0?[1-9]):([0-5][0-9])([AaPp][Mm]))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(1[0-2]|0?[1-9]):([0-5][0-9])([AaPp][Mm])(?:\\|(1[0-2]|0?[1-9]):([0-5][0-9])([AaPp][Mm]))*$', 'gm')
const str = `12:00am
12:00am|1:20PM|9:30Pm
12:00am|1:20PM
12:00am|1:20PM|9:3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}