using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">([0-9]{10})[-<;]\s{1,2}([0-9]{4})([0-9]{5})#(\s([0-9_\?]{0,8}))?(\+\s([a-z0-9_\?]{0,5}))?(\-\s([\.,0-9_\?]{0,10})>)?";
string input = @">1234567890< 123451234#";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}