re = /(?<=~).*?(?=,(?:GO:\d+~|$))/m
str = 'GO:0016559~peroxisome fission,
GO:0006122~mitochondrial electron transport, ubiquinol to cytochrome c,
GO:0006122~mitochondrial electron transport, ubiquinol to cytochrome c,GO:0006334~nucleosome assembly,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end