import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\/(?<mnemonic>.{2,8}?)_(?<isbn>\\d{13})_(?<primaryId>all|tx\\d{0,3}|lay\\d{0,3}|c0\\d{1,3}|c[^0]\\d{1,2}?)_(?<secondaryId>(\\d{1,2}|x)p)(?:_r(?<revisionNumber>\\d+))?\\.(?<extension>indd|qxp|qxd)$\n";
final String string = "Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_0p_r3.indd\n"
+ "Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_1p_r3.indd\n"
+ "Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_2p_r3.indd\n"
+ "Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_123p_r3.indd\n"
+ "Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_tx_xp_r3.indd\n\n"
+ "Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}