const regex = /^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<secondaryId>(\d{1,2}|x)p)(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\\/(?<mnemonic>.{2,8}?)_(?<isbn>\\d{13})_(?<primaryId>all|tx\\d{0,3}|lay\\d{0,3}|c0\\d{1,3}|c[^0]\\d{1,2}?)_(?<secondaryId>(\\d{1,2}|x)p)(?:_r(?<revisionNumber>\\d+))?\\.(?<extension>indd|qxp|qxd)$
', 'gm')
const str = `Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_0p_r3.indd
Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_1p_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_2p_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_123p_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_tx_xp_r3.indd
Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}