package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z]([a-záéúőóüö.]+\s?)){2,}$`)
var str = `John T. Doe
John T. Doe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}