$re = '/^([A-Z]([a-záéúőóüö.]+\s?)){2,}$/m';
$str = 'John T. Doe
John T. Doe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);