package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{11}\b`)
var str = `12345678987
123456789876
1234 5678987
11223344556
A1234B5678987`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}