$re = '/\b\d{11}\b/m';
$str = '12345678987
123456789876
1234 5678987
11223344556
A1234B5678987';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);