#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)0\|Trend Micro\|[a-zA-Z0-9_ ]*\|\d+\|(([a-zA-Z]+)(\W+)([a-zA-Z0-9]+))\|[a-zA-Z0-9_ ]*\|\d+\|"
Local $sString = "0|Trend Micro|Apex Central|2019|BM:1000|Behavior Monitoring|3|"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")