$re = '/0\|Trend Micro\|[a-zA-Z0-9_ ]*\|\d+\|(([a-zA-Z]+)(\W+)([a-zA-Z0-9]+))\|[a-zA-Z0-9_ ]*\|\d+\|/m';
$str = '0|Trend Micro|Apex Central|2019|BM:1000|Behavior Monitoring|3|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);