using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\S+| (?!(?=[IVXLCDM])(M*)(C[MD]|D?C{0,3})(X[CL]|L?X{0,3})(I[XV]|V?I{0,3})$))+";
string input = @"Joe
Bob
Carl
Seth Smith II
Doug IV
John Doe LIV
Jane Black MMXIX
Francis LIVERPOOL
Maragaret White MCMLXXXIV
Jennifer Brown DIX
Jet LI II
Jet LI
Jeniffer Li VII
Jorge Fernandondo Gutiérrez Fernández XIII
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}