re = /^(?:\S+| (?!(?=[IVXLCDM])(M*)(C[MD]|D?C{0,3})(X[CL]|L?X{0,3})(I[XV]|V?I{0,3})$))+/m
str = 'Joe
Bob
Carl
Seth Smith II
Doug IV
John Doe LIV
Jane Black MMXIX
Francis LIVERPOOL
Maragaret White MCMLXXXIV
Jennifer Brown DIX
Jet LI II
Jet LI
Jeniffer Li VII
Jorge Fernandondo Gutiérrez Fernández XIII
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end