using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\.)\b\d+(?:\.\d+){3}\b(?!\.)";
string input = @"1.1.1.1
1.1.1.1.
1.1.1.1.1
1.11.1.1.1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}