re = /(?<!\.)\b\d+(?:\.\d+){3}\b(?!\.)/m
str = '1.1.1.1
1.1.1.1.
1.1.1.1.1
1.11.1.1.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end