#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[.+\] (?!tired\.0003).+\n(.+)\n{2}(?:\[.+\] tired\.0003\n(.+)\n{2})"
Local $sString = "[18-Feb-21 03:31 PM] tired.#0003" & @CRLF & _
"from the thumbnail" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[18-Feb-21 03:31 PM] tired.#0003" & @CRLF & _
"this is either about to go good or bad" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[18-Feb-21 03:32 PM] anonymous#0000" & @CRLF & _
"It’s neither" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[18-Feb-21 03:32 PM] tired.#0003" & @CRLF & _
"sad" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[18-Feb-21 03:32 PM] anonymous#0000" & @CRLF & _
"I wonder if I can cause it to be removed"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")