using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[.+\] (?!tired\.0003).+\n(.+)\n{2}(?:\[.+\] tired\.0003\n(.+)\n{2})";
string input = @"[18-Feb-21 03:31 PM] tired.#0003
from the thumbnail
[18-Feb-21 03:31 PM] tired.#0003
this is either about to go good or bad
[18-Feb-21 03:32 PM] anonymous#0000
It’s neither
[18-Feb-21 03:32 PM] tired.#0003
sad
[18-Feb-21 03:32 PM] anonymous#0000
I wonder if I can cause it to be removed";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}