const regex = /.*Z\.VALUE_01.*\s+AS\s+(?<Alias>[^,\s]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*Z\\.VALUE_01.*\\s+AS\\s+(?<Alias>[^,\\s]*)', 'gm')
const str = `CREATE VIEW ABC
AS SELECT
Z.NUMBER AS ID,
Z.LANGUAGE AS LNG,
SUBSTR(Z.VALUE_01,01,02) AS RUN_NUMB,
SUBSTR(Z.TXT_VALUE_01,01,79) AS TXT FROM
MYTABLE Z
WHERE ID = '0033'
AND LNG = 'DE'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}