$re = '/.*Z\.VALUE_01.*\s+AS\s+(?<Alias>[^,\s]*)/m';
$str = 'CREATE VIEW ABC
AS SELECT
Z.NUMBER AS ID,
Z.LANGUAGE AS LNG,
SUBSTR(Z.VALUE_01,01,02) AS RUN_NUMB,
SUBSTR(Z.TXT_VALUE_01,01,79) AS TXT FROM
MYTABLE Z
WHERE ID = \'0033\'
AND LNG = \'DE\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);