// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/var\/log\/containers\/container_name_\w{27}.log$").unwrap();
let string = "/var/log/containers/container_name_fdsdjkfasdfads5f4s6dfsda65f.log";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}