import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-fA-F0-9]{40}$";
final String string = "md5\n"
+ "66682880b58943ac2358aa5416a5880f\n"
+ "f0b7fdf47863b4d6d018e35c25c66169\n"
+ "8f57434b9a58fbbe29c999df50ffecc2\n\n\n"
+ "sha1\n"
+ "10886660c5b2746ff48224646c5094ebcf88c889\n"
+ "7b650a8ce213738d38b60ee9d99ffae8def286e5\n"
+ "4e9429cec96a08face2c8deeb01c27228b725ed2\n\n\n\n"
+ "sha256\n"
+ "746df05c8f3a0b07a46c0967cfbc5cbe5b9d48d0f79b6177eeedf8be6c8b34b5\n"
+ "a1efca12ea51069abb123bf9c77889fcc2a31cc5483fc14d115e44fdf07c7980\n"
+ "a1f0b78b8c1320690327800e3a5de10e7dbba7b6c752e702193a395a52c727b6\n\n\n\n"
+ "test\n"
+ "f more\n"
+ "a1f0b78b8c1320690327800e3a5de10e7dbba7grtgrtc752e702193a395a5w2c7b6\n\n"
+ "a1f0b78b8c1320690327800e3a5de10e7dbba7b6c752e702193a395a52c7\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}