import re
regex = re.compile(r"^[a-fA-F0-9]{40}$", flags=re.MULTILINE)
test_str = ("md5\n"
"66682880b58943ac2358aa5416a5880f\n"
"f0b7fdf47863b4d6d018e35c25c66169\n"
"8f57434b9a58fbbe29c999df50ffecc2\n\n\n"
"sha1\n"
"10886660c5b2746ff48224646c5094ebcf88c889\n"
"7b650a8ce213738d38b60ee9d99ffae8def286e5\n"
"4e9429cec96a08face2c8deeb01c27228b725ed2\n\n\n\n"
"sha256\n"
"746df05c8f3a0b07a46c0967cfbc5cbe5b9d48d0f79b6177eeedf8be6c8b34b5\n"
"a1efca12ea51069abb123bf9c77889fcc2a31cc5483fc14d115e44fdf07c7980\n"
"a1f0b78b8c1320690327800e3a5de10e7dbba7b6c752e702193a395a52c727b6\n\n\n\n"
"test\n"
"f more\n"
"a1f0b78b8c1320690327800e3a5de10e7dbba7grtgrtc752e702193a395a5w2c7b6\n\n"
"a1f0b78b8c1320690327800e3a5de10e7dbba7b6c752e702193a395a52c7\n\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")