import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(1[3|4|5|7|8][0-9]{9})";
final String string = "抵离城市\n"
+ "/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安\n"
+ "西安\n"
+ "/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "重庆/\n"
+ "/上海\n"
+ "上海\n"
+ "上海/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "重庆/成都\n"
+ "成都/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/北京\n"
+ "/北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安\n"
+ "西安/武汉/宜昌\n"
+ "CRUISE\n"
+ "CRUISE\n"
+ "CRUISE\n"
+ "重庆/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/上海\n"
+ "上海\n"
+ "上海/\n"
+ "/上海\n"
+ "上海\n"
+ "上海/北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安\n"
+ "西安/上海\n"
+ "自行安排\n"
+ "/上海\n"
+ "上海\n"
+ "上海/\n"
+ "/上海\n"
+ "上海\n"
+ "上海/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "重庆/成都\n"
+ "成都/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安\n"
+ "西安/成都\n"
+ "成都\n"
+ "成都/上海\n"
+ "上海\n"
+ "上海/\n"
+ "/北京\n"
+ "北京\n"
+ "北京\n"
+ "/北京\n"
+ "北京\n"
+ "北京/西安/北京\n"
+ "北京\n"
+ "北京/桂林\n"
+ "桂林/阳朔/桂林\n"
+ "桂林/\n"
+ "/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔/桂林\n"
+ "桂林/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安/成都\n"
+ "成都\n"
+ "成都\n"
+ "成都/\n"
+ "/重庆/成都\n"
+ "/北京甄桢 Jeniffer 13811816407\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/桂林 刘智13006935016\n"
+ "桂林/阳朔\n"
+ "阳朔/桂林\n"
+ "桂林/龙脊\n"
+ "桂林/\n"
+ "/北京武鹏 Peter 18601263451\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/拉萨\n"
+ "拉萨\n"
+ "拉萨\n"
+ "拉萨\n"
+ "拉萨/江孜\n"
+ "江孜/日喀则\n"
+ "日喀则/拉萨\n"
+ "拉萨/\n"
+ "/北京杨月 Tina 18611864327\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "成都/乐山/成都\n"
+ "成都/\n"
+ "/广州 ROBERT,牛宇东,13602746572\n\n"
+ "广州\n"
+ "广州/\n"
+ "/北京杨筠 Crystal 15910459329\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安贾志兴13519137267\n"
+ "西安\n"
+ "西安\n"
+ "/上海\n"
+ "上海/乌镇/上海\n"
+ "上海\n"
+ "上海/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/泉州 不需要导游\n"
+ "泉州\n"
+ "泉州\n"
+ "广州 不需要导游\n\n"
+ "香港/北京马丽雯133 4111 1559\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安张瑞18802921905\n"
+ "西安\n"
+ "西安/上海 吴蓓 Grace 13916691143\n"
+ "上海\n"
+ "上海\n"
+ "上海/杭州王寅磊13666623543/上海\n"
+ "上海/\n"
+ "香港/北京 赵璋13641005628\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安 高战朋18729599977\n"
+ "西安\n"
+ "西安/上海 李德宇 David 13524394499\n"
+ "上海\n"
+ "上海/悉尼\n"
+ "桂林/三亚金开江george13907607205\n"
+ "三亚\n"
+ "三亚\n"
+ "三亚\n"
+ "三亚\n"
+ "三亚\n"
+ "/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "北京杨筠 Crystal 15910459329/哈尔滨 果巍13263551211\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨/北京\n"
+ "/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海\n"
+ "上海\n"
+ "/桂林\n"
+ "桂林/龙胜/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/\n"
+ "/北京:马丽雯133 4111 1559\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n\n"
+ "/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨/亚布力\n"
+ "亚布力\n"
+ "亚布力/哈尔滨/\n"
+ "/北京\n"
+ "北京\n"
+ "北京\n"
+ "/北京李景媛13521658180\n"
+ "北京\n"
+ "北京/\n"
+ "/北京 谢宏坤Kathleen 13910055287\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安 刘宇13991296445\n"
+ "西安/成都\n"
+ "成都 黄骞ALEX 15378187551\n"
+ "成都/\n"
+ "上海/\n"
+ "杨娟 Young 13916291180\n"
+ "上海\n"
+ "上海\n"
+ "上海/北京\n"
+ "上海/哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨/上海\n"
+ "周一飞 13661759800 Steven\n"
+ "上海\n"
+ "上海/成都\n"
+ "Viola 乐建君18980647351\n"
+ "成都\n"
+ "成都/乐山/成都\n"
+ "成都/\n"
+ "北京/\n"
+ "武鹏 Peter 18601263451\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "/北京杨月 Tina 18611864327\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "苏黎世/北京 赵璋13641005628\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/哈尔滨 王莹 18610662338\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨/北京 赵璋13641005628\n"
+ "北京\n"
+ "北京/悉尼\n"
+ "/上海 \n"
+ " 年永丰 Jerri 13611724334 /北京/ 陈涛 Barry 15201331832\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/上海\n"
+ "/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安\n"
+ "西安/\n"
+ "/北京陈涛 Barry 15201331832\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安张瑞18802921905\n"
+ "西安\n"
+ "西安/上海\n"
+ "/哈尔滨 高原 13674681528\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨/\n"
+ "/北京甄珍 Jennifer 13811816407\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "/重庆/上海/伦敦\n"
+ "/北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/\n"
+ "/北京李景媛 Tracy 13521658180\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安高战朋Jason\n"
+ "18729599977\n"
+ "西安/成都钟国平 EDDIE 15902849483\n"
+ "成都/乐山/成都\n"
+ "成都\n"
+ "成都/\n"
+ "/北京/哈尔滨王学鹏 139 3664 4706\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨/北京\n"
+ "北京/\n"
+ "/北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/\n"
+ "成都/上海\n"
+ "上海\n"
+ "上海/\n"
+ "/北京于爽 SELINA 13522726539\n"
+ "/北京\n"
+ "/北京\n"
+ "/北京\n"
+ "北京/\n"
+ "成都/九寨沟\n"
+ "九寨沟\n"
+ "九寨沟/成都\n"
+ "成都/\n"
+ "/上海 \n"
+ "周一飞 Steven 13661759800\n"
+ "上海\n"
+ "上海/乌镇/上海\n"
+ "上海\n"
+ "上海/西安\n"
+ "西安姜何新13571941112\n"
+ "西安/北京\n"
+ "北京 甄桢 Jennifer 13811816407\n"
+ "北京\n"
+ "北京/\n"
+ "/重庆/游船\n"
+ "游船\n"
+ "游船\n"
+ "宜昌\n"
+ "/昆明\n"
+ "昆明/丽 江\n"
+ "丽江\n"
+ "丽江/西双版纳\n"
+ "景洪\n"
+ "景洪/昆明\n"
+ "昆明/建水\n"
+ "元阳\n"
+ "元阳\n"
+ "元阳/石林\n"
+ "昆明/成都\n"
+ "温江\n"
+ "成都\n"
+ "成都/\n\n"
+ "/北京杨月 Tina 18611864327\n"
+ "北京/哈尔滨王学鹏13936644706\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨/北京\n"
+ "/北京甄桢 Jeniffer 13811816407\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨\n"
+ "哈尔滨/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/\n"
+ "上海/厦门/漳州\n"
+ "Hanson, 黄伟华13950050178\n"
+ "漳州\n"
+ "漳州/诏安\n"
+ "诏安\n"
+ "诏安/厦门/上海\n"
+ "年永丰 Jerri \n"
+ "13611724334\n"
+ "上海/\n"
+ "/北京李满红 robert 13910402294\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安高战朋18729599977\n"
+ "西安\n"
+ "西安\n"
+ "上海 许佳 13482319012\n"
+ "上海\n"
+ "上海\n"
+ "上海/香港\n"
+ "/北京 赵璋13641005628\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/上海\n"
+ "上海/乌镇/上海\n"
+ "上海\n"
+ "上海/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/上海\n"
+ "上海\n"
+ "上海/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "/重庆/成都\n"
+ "成都/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "北京/哈尔滨王学鹏 13936644706\n"
+ "哈尔滨\n"
+ "哈尔滨/北京\n"
+ "/长沙\n"
+ "长沙\n"
+ "长沙\n"
+ "长沙\n"
+ "长沙\n"
+ "长沙\n"
+ "/成都 \n"
+ "刘雨哲18982231703\n\n"
+ "成都\n"
+ "成都/乐山/成都\n"
+ "成都/上海\n"
+ "/北京陈涛 Barry 15201331832\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安贾志兴13519137267\n"
+ "西安\n"
+ "西安/\n"
+ "/北京李满红 ROBERT\n"
+ "13910402294\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安/成都\n"
+ "成都/乐山/成都\n"
+ "成都\n"
+ "成都/\n"
+ "/北京 赵璋\n"
+ "13641005628\n"
+ "北京/哈尔滨 徐喜峰 18045086977\n"
+ "哈尔滨\n"
+ "哈尔滨/北京 赵璋\n"
+ "13641005628\n"
+ "北京/拉萨 次多(Tseduo)13989015981\n"
+ "拉萨\n"
+ "拉萨\n"
+ "拉萨/江孜\n"
+ "江孜/日喀则\n"
+ "日喀则/拉萨\n"
+ "拉萨/北京 赵璋\n"
+ "13641005628\n"
+ "北京/大同 刘洋13994219545\n"
+ "大同\n"
+ "大同/平遥\n"
+ "平遥/太原\n"
+ "太原/北京/\n"
+ "/上海年永丰13611724334/西安刘宇\n"
+ "13991296445\n"
+ "西安\n"
+ "西安/上海\n"
+ "上海\n"
+ "上海/\n"
+ "悉尼/上海 周一飞 Steven 13661759800\n"
+ "大阪/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/桂林 黎江13457669394 LEE\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/西安邹欣13720586130\n"
+ "西安\n"
+ "西安/北京 甄珍 Jennifer 13811816407\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/香港\n"
+ "北京/首尔\n"
+ "/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/上海/苏州\n"
+ "苏州\n"
+ "苏州\n"
+ "苏州/杭州\n"
+ "杭州\n"
+ "杭州/上海/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔/桂林/\n"
+ "/上海\n\n"
+ "北京/桂林黎江 Lee 13457669394\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/广州\n"
+ "/上海/乌镇/上海李德宇 13524394499\n"
+ "/北京李满红 ROBERT 13910402294\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安高旭飞15091373169\n"
+ "西安\n"
+ "西安/\n"
+ "北京/上海\n"
+ "北京导游Robert 13910402294\n"
+ "上海导游李德宇 13524394499\n"
+ "北京/上海吴蓓13916691143\n\n\n"
+ "上海/\n"
+ "/上海\n"
+ "上海/乌镇/上海\n"
+ "上海\n"
+ "上海/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "香港/北京/香港\n"
+ "杭州/上海\n"
+ "/北京陈涛 Barry 15201331832\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/北京杨月 TINA 18611864327\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安张茹15388697575\n"
+ "西安\n"
+ "西安/\n"
+ "/昆明\n"
+ "昆明/大理\n"
+ "大理\n"
+ "大理/丽江\n"
+ "丽江\n"
+ "丽江/中甸\n"
+ "中甸\n"
+ "中甸\n"
+ "中甸/昆明\n"
+ "昆明/石林\n"
+ "石林/建水\n"
+ "建水/元阳\n"
+ "元阳\n"
+ "元阳/通海/昆明\n"
+ "昆明\n"
+ "/上海\n"
+ "上海\n"
+ "上海/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "/重庆/成都\n"
+ "成都/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/长沙叶佳MICHELLE 18673118364\n"
+ "/韶山\n"
+ "韶山/长沙\n"
+ "长沙/张家界\n"
+ "张家界\n"
+ "张家界/长沙\n"
+ "长沙/\n"
+ "/上海宋鑫瑜13681967941\n\n"
+ "上海\n"
+ "上海/北京李满红 ROBERT 13910402294\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/北京陈涛 Barry 15201331832\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/上海张静Elva15216778040\n"
+ "上海/\n"
+ "/上海\n"
+ "上海/乌镇/上海\n"
+ "上海\n"
+ "上海/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/广州王娜RINA 15889936788\n"
+ "广州\n"
+ "广州\n"
+ "广州/桂林涂圣梓 Sherry 15078943056\n"
+ "桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/\n"
+ "/北京盛倩云 13671211703\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/北京陈涛 Barry 15201331832\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安高旭飞\n"
+ "15091373169\n"
+ "西安\n"
+ "西安/成都Dave 13980413001\n"
+ "成都/ 吴蓓 13916691143\n"
+ "上海\n"
+ "上海\n"
+ "上海/上海码头\n"
+ "/北京\n"
+ "于爽 Selinna 13522726539\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安 刘笑南13891999984\n"
+ "西安/上海\n"
+ "上海/乌镇/上海\n"
+ "上海 \n"
+ "周一飞 Steven 13661759800\n"
+ "上海\n"
+ "上海/\n"
+ "/拉萨\n"
+ "拉萨\n"
+ "拉萨\n"
+ "拉萨\n"
+ "拉萨/北京\n"
+ "北京\n"
+ "北京\n"
+ "/北京 无\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/北京焦晓旭 George 18010155516\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安\n"
+ "西安/上海 吴蓓 Grace 13916691143\n"
+ "上海/苏州/上海\n"
+ "上海\n"
+ "上海/\n"
+ "/上海\n"
+ "林荣军 Albert\n"
+ "13918508768\n"
+ "上海/乌镇/上海\n"
+ "/西安高森13992808727\n"
+ "西安\n"
+ "西安/北京赵璋13641005628\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "桂林/香港\n"
+ "/上海\n"
+ "上海/乌镇/上海\n"
+ "上海\n"
+ "上海/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/桂林黎江 Lee 13457669394\n"
+ "桂林\n"
+ "桂林/龙脊/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林\n"
+ "桂林/\n"
+ "/北京\n"
+ "盛倩云 ANNA 13671211703\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "杜建峰13488142605\n"
+ "西安\n"
+ "西安/昆明\n"
+ "/北京\n"
+ "/北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安\n"
+ "西安/武汉/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "/重庆/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/上海\n"
+ "上海\n"
+ "上海/\n"
+ "桂林/香港\n"
+ "/上海\n"
+ "上海\n"
+ "上海/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "/重庆/成都\n"
+ "成都/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/上海\n"
+ "上海/\n"
+ "/上海李德宇 David 13524394499\n"
+ "上海\n"
+ "上海/\n"
+ "/上海\n"
+ "上海/乌镇/上海\n"
+ "上海\n"
+ "上海/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/北京\n"
+ "/北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安\n"
+ "西安/武汉/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "重庆\n"
+ "/重庆/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/上海\n"
+ "上海\n"
+ "上海/\n"
+ "/北京\n"
+ "/北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安\n"
+ "西安/武汉/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "重庆\n"
+ "/重庆/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/上海\n"
+ "上海\n"
+ "上海/\n"
+ "/上海\n"
+ "上海\n"
+ "上海/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "/重庆/成都\n"
+ "成都/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "新加坡/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/西安\n"
+ "西安\n"
+ "西安/武汉/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "/重庆/成都\n"
+ "成都/昆明\n"
+ "昆明\n"
+ "昆明/大理\n"
+ "大理\n"
+ "大理/昆明/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/杭州\n"
+ "杭州\n"
+ "杭州/苏州\n"
+ "苏州\n"
+ "苏州/上海\n"
+ "上海\n"
+ "上海/新加坡\n"
+ "新加坡/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/西安\n"
+ "西安\n"
+ "西安/武汉/宜昌\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "/重庆/成都\n"
+ "成都/昆明\n"
+ "昆明\n"
+ "昆明/大理\n"
+ "大理\n"
+ "大理/昆明/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔\n"
+ "阳朔/桂林/杭州\n"
+ "杭州\n"
+ "杭州/苏州\n"
+ "苏州\n"
+ "苏州/上海\n"
+ "上海\n"
+ "上海/新加坡\n"
+ "成都孙进 DAVID 13980413001/西安杨韬 Jason 13325473009\n"
+ "西安\n"
+ "西安\n"
+ "西安杨韬 Jason 13325473009/北京程海江 Peter 13621220391\n"
+ "北京\n"
+ "香港/北京李满红 Robert 13810402294\n"
+ "/香港\n"
+ "/北京盛倩云13671211703\n"
+ "北京/西安赵红13891826887\n"
+ "西安\n"
+ "西安\n"
+ "/上海 杨孟雪 Allison 15021562791\n"
+ "上海\n"
+ "上海/宜昌 冯伟 Gary 13872500040\n"
+ "/游船\n"
+ "游船\n"
+ "游船\n"
+ "游船\n"
+ "\"游船/重庆 杨淼慧Miaomiao,15123908807 /西安邹欣13720586130\"\n"
+ "西安\n"
+ "西安/上海杨孟雪 Allison 15021562791/\n"
+ "/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安\n"
+ "西安\n"
+ "西安/成都\n"
+ "成都/上海\n"
+ "上海\n"
+ "上海/黄山/屯溪\n"
+ "黄山\n"
+ "黄山/屯溪/上海\n"
+ "上海/\n"
+ "北京/上海\n"
+ "/昆明尹晓妍 Yin 15287105310/大理 赵志强 ZHAO 13987255735\n"
+ "大理\n"
+ "大理\n"
+ "大理/丽江 李凤仙 SUNNY 15287272631\n"
+ "丽江\n"
+ "丽江\n"
+ "丽江\n"
+ "丽江/昆明/尹晓妍 Yin 15287105310\n\n"
+ "/厦门Victor 丘 13599504264\n\n"
+ "/上海 吴蓓 Grace 13916691143\n"
+ "/北京谢宏坤 Kathleen 13910055287\n"
+ "北京\n"
+ "北京/\n"
+ "/上海许佳Melody13482319012\n"
+ "上海\n"
+ "上海/北京盛倩云 13671211703\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/北京赵璋13641005628\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "北京\n"
+ "张玉琪 Richard\n"
+ "13911306905\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "北京\n"
+ "李满红 ROBERT 13910402294\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "北京/西安贾志兴13519137267\n"
+ "西安\n"
+ "西安/北京\n"
+ "/上海\n"
+ "上海/乌镇/上海\n"
+ "上海\n"
+ "上海/西安\n"
+ "西安\n"
+ "西安/北京\n"
+ "北京\n"
+ "北京\n"
+ "北京/\n"
+ "/成都\n"
+ "成都\n"
+ "成都/丽江\n"
+ "丽江\n"
+ "丽江/昆明/桂林\n"
+ "桂林/阳朔\n"
+ "阳朔/桂林\n"
+ "桂林/上海\n"
+ "上海\n"
+ "上海\n"
+ "上海\n"
+ "上海/\n"
+ "/成都\n"
+ "/北京\n"
+ "北京/\n"
+ "/北京李满红 Robert Lee 13910402294\n"
+ "北京\n"
+ "北京\n"
+ "北京/上海 张伟 Troy 13795428426\n"
+ "上海\n"
+ "上海\n"
+ "上海/苏州/上海\n"
+ "上海/\n"
+ "芝加哥/北京 赵璋13641005628\n"
+ "西雅图/北京 赵璋13641005628\n"
+ "北京\n"
+ "北京\n"
+ "北京/西安 邹欣13720586130\n"
+ "西安\n"
+ "西安/武汉周涛13317173828\n"
+ "/宜昌潘奕13477122377\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}