using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{9,9})(?=\))";
string input = @"merridzhner:2pRqBx|Instagram 183.0.0.40.116 Android (23/6.0.1; 320dpi; 1080x1920; Fly; Flylife; Flylife Connect 7.85 3G 2; h1; ru_KZ; 283072592)|android-ba97928a3a338e73;0871b7aa-7794-4f05-954c-593c015ae38f;b83b6ddc-b663-4657-861a-d1f094e733e0;5699c2ff-f6db-4c25-82b0-0aaa48a9816e|ds_user=merridzhjejnturner;igfl=merridzhner;csrftoken=HS8Lidz6l0H9b4opN847dSSvylsNE0Ie;mid=YIK3qAABAAGKwWHhF9fxYsNVTrz9;rur=VLL;ds_user_id=47568548744;sessionid=47568548744%3AXSJzhpEiticHZC%3A8;ig_did=7ABBF373-5D2C-403F-9AE5-71C598984491;||";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}