# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]{9,9})(?=\))"
test_str = "merridzhner:2pRqBx|Instagram 183.0.0.40.116 Android (23/6.0.1; 320dpi; 1080x1920; Fly; Flylife; Flylife Connect 7.85 3G 2; h1; ru_KZ; 283072592)|android-ba97928a3a338e73;0871b7aa-7794-4f05-954c-593c015ae38f;b83b6ddc-b663-4657-861a-d1f094e733e0;5699c2ff-f6db-4c25-82b0-0aaa48a9816e|ds_user=merridzhjejnturner;igfl=merridzhner;csrftoken=HS8Lidz6l0H9b4opN847dSSvylsNE0Ie;mid=YIK3qAABAAGKwWHhF9fxYsNVTrz9;rur=VLL;ds_user_id=47568548744;sessionid=47568548744%3AXSJzhpEiticHZC%3A8;ig_did=7ABBF373-5D2C-403F-9AE5-71C598984491;||"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.