re = /(\d{4,5})\s(.*)/m
str = '35460 Bad Soden am Taunus
D-76275 Musterstadt
6275 Musterstadt 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end