$re = '/[A-Z][a-z]+[A-Z][a-z]+[0-9]+/m';
$str = 'TestAc9211
Testacc301
ExampleRecord111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);