$re = '/.*NSO.HORDIN_XMLDAFNEV.*.xml/m';
$str = '0641.NSO.HORDIN_XMLDAFNEV3.0019320533.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);