re = /.*NSO.HORDIN_XMLDAFNEV.*.xml/m
str = '0641.NSO.HORDIN_XMLDAFNEV3.0019320533.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end